UIM error in nas log: nas: invalid posting <primary hub IP>/48002, missing 'message' and/or 'nimid'
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Article ID: 125734
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Updated On:
Products
NIMSOFT PROBESDX Infrastructure Management
Issue/Introduction
UIM nas log has these messages even though it is set for log level 0: Jan 31 09:50:07:516 [54996] nas: invalid posting x.x.x.x.5/48002, missing 'message' and/or 'nimid'
Cause
The message is to be understood at face value, that an alarm came in that is missing the nimID and or message. When viewing alarms in the IM console Alarm Window the ID = nimID
Ideally it will be possible to identify these alarms from the IM console Alarm Window via the empty ID or message field.
Another option is to add a new Attach queue named something like TestNas and Subject alarm2. The messages in the queue can be viewed one at a time via DrNimBUS which can be started either via the shortcut in the program group or C:\Program Files (x86)\Nimsoft\bin\DrNimBUS.exe. Click the View Messages In Queue button, third from the left click the maximize button check the box for 'Show header' click the + to pull the next message from the queue On the right check to see if the 'message' field is missing.
Note: this should not be done with production queues since it will remove the message from the queue, preventing it from being processed as it normally would have.
Environment
Release: Component: UIMNAS
Resolution
Review the probe settings at the robot and if nothing stands out to suspect: Deploy the GA build If the problem persists: deactivate the probe make a backup copy of the probe folder activate the probe delete the probe from the IM console remove the probe folder deploy the GA build configure & test
DrNimBUS can be used to verify it has been resolved. Select the Message Sniffer (second icon from the left) click the maximize button check the box for 'Show header' Add filters for both the robot & probe Click the green "play" button Wait for alarms