Invalid Signature error when configuring SAML2 with signing
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Invalid Signature error when configuring SAML2 with signing

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Article ID: 125507

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Updated On:

Products

CA Performance Management Network Observability

Issue/Introduction

After setting up SAML2 with signing, the follwong error is seen in the PC_HOME/sso/logs/SsoService.log:

ERROR | qtp1649115615-37 | <timestamp> | common.sso.saml2.UserAssertionService 
| Receive StatusCode: urn:oasis:names:tc:SAML:2.0:status:Requester. Message: Invalid signature 

And login fails for SAML2 authenticated users.

Environment

DxNetOps Performance Management

SAML2 authentication with signing

Cause

There is a mismatch between the Metadata/Certificate information the IDP has from NetOps Portal

Resolution

Make sure the documentation is followed closely and the IDP has up to date Metadata from NetOps Portal

Additional Information

SAML 2.0 Authentication in Single-Sign On