Agent for Oracle E-Business Suite fails to start with "ORA-01017: invalid username/password; logon denied"
search cancel

Agent for Oracle E-Business Suite fails to start with "ORA-01017: invalid username/password; logon denied"

book

Article ID: 125452

calendar_today

Updated On:

Products

Workload Automation Agent

Issue/Introduction

Workload Automation Agent with Oracle E-Business Suite (plugin) fails to start with error in oa.log file;

01/29/2019 07:17:27.756 CST-0600 1 main.MainThread.CybOaPluginDriver.runApplication[:152] - OaDbHandler initialization failed. ORA-01017: invalid username/password; logon denied

01/29/2019 07:17:27.756 CST-0600 1 main.MainThread.CybOaPluginDriver.runApplication[:171] - OA plugin initialization problem - TERMINATING


In defaultlog_agent.log;
01/29/2019 07:17:27.760 CST-0600 1 main.MainThread.CybAgentDriver.runApplication[:389] - cybermation.library.plugins.CybPluginException: Plugin instantiation failed

 Caused by: cybermation.library.plugins.CybPluginInitializationException: OA plugin initialization problem - TERMINATING

 

Environment

CA Workload Automation Agent for Oracle E-Business Suite (ORCAGD, ORCAGT)

Cause


The Oracle E-Business Suite plugin is terminating due to invalid username/password to connect to the Oracle Applications database. It's likely the password has been changed on the Oracle Applications side.

Resolution

Ensure that the user ID and encrypted password to connect to the Oracle Applications database are valid in the Agent's agentparm.txt file.
Example:
oa.db.accessId=apps
oa.db.accessPassword=12345XXXXXXXXXXX

Use the password utility in the agent installation directory to encrypt the password.
 




 

Additional Information

Change the Default Database User ID and Password