DE 12.1 Server SHUTDOWN due to port conflict

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Article ID: 125397

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Updated On:

Products

DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

The Primary Workload Automation DE unexpectedly shutdown and successful rollover to Secondary DE Server.

Cause

The Primary DE Server shutdown due to problem binding to the Desktop Client port (default 7500).
- Possible conflict in Desktop Client port. 
- Another application installed on the DE Server host is using the Desktop Client port.

The following error is reported in the DE Server tracelog and errors.txt files;

Server terminated with an error code of 3. The exception is com.ca.wa.comp.workstationserver.WAWorkstationServerException: java.net.BindException: Address already in use: bind.com.ca.wa.comp.workstationserver.WAWorkstationServerException: java.net.BindException: Address already in use: bind

Caused by: java.net.BindException: Address already in use: bind

 

Environment

CA Workload Automation DE (dSries) 11.3 and 12.x including High Availability (HA)

Resolution

Make sure no other application is using the DE Server ports (Default 7507, 7500, 7598, 7599). If any conflict, change the DE Server port in Admin -> Topology -> Configure Instance Parameters.
Note - Restart the DE Server for the change to take effect. If High Availability (HA), restart both the primary and secondary servers.





 

Additional Information

Change Server Port Numbers