Information TAB has no data after upgraded to 10.3.0

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Article ID: 125304

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Updated On:

Products

CA Spectrum

Issue/Introduction

Since upgraded to CA Spectrum 10.3.0, the Information TAB has no data for Cisco 1811 and 1841.
 

Cause

Identified the root cause associated with two sub views added in 10.3 which are reading some dynamic attributes from device and taking long time:
- AlternateCiscoIPRoutingTable
- CiscoIPRoutingTable

Environment

CA Spectrum 10.3.0

Resolution

Please comment below sub views in the $SPECROOT/tomcat/webapps/spectrum/WEB-INF/topo/config/view-devicedetails-config.xml file as follows (note the added <!-- and -->):.

<!--
<application-subview>
      <title>com.aprisma.spectrum.app.topo.client.AlternateCiscoIPRoutingTable</title>
      <privilege><name>CiscoIPRoutingTable</name></privilege>
      <model-type>0x210016</model-type>
  <display-if>
    <expression>attr(0x100b1) == null</expression>
  </display-if>
  <subviews>
  <subview-group>
<subviews>
  <table-subview idref="table-cisco-ip-routingtable-config-new"/>
    </subviews>
  </subview-group>
  </subviews>
</application-subview>

<application-subview>
      <title>com.aprisma.spectrum.app.topo.client.CiscoIPRoutingTable</title>
      <privilege><name>CiscoIPRoutingTable</name></privilege>
      <model-type>0x210016</model-type>
  <display-if>
    <expression>attr(0x100b1) != null</expression>
  </display-if>
  <subviews>
  <subview-group>
<subviews>
  <table-subview idref="table-cisco-ip-routingtable-config"/>
    </subviews>
  </subview-group>
  </subviews>
</application-subview>

-->
Please comment line number from 198 to 228 and restart OneClick Client and verify the behavior.