Delayed Server Response when looking at some Change Order Details pages

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Article ID: 125291

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When viewing Change Order Details pages on some Change Orders, a Delayed Server Response error comes up.

Cause

During the process of troubleshooting (using a browser console), it was observed that below is the request that the browser attempts:

GET /CAisd/pdmweb.exe?SID=123456789+FID=1234+OP=VALIDATE_CHG_SCHEDULE+FACTORY=chg+sched_start_date=1549339200+sched_end_date=1548734400asset_length=0+change_id=12345+TENANT_ID=ABCD123456


 

Environment

Release:
Component: USRD

Resolution

Notice that the Scheduled Start Date is greater than Scheduled End Date.  Normally this should not be the case and SDM UI does not allow one to put values like this. Somehow the values made it to the database externally.

This is causing the Change Orders not to display properly as the webengine which processes these records and prepares the HTML for the browser, that program was not handling such a condition properly. 

CA is working on a solution for the same.

As a work around, update appropriate Change Order to have a correct Scheduled Start Date (which is earlier or equal to the Scheduled End Date).  This can be done via a pdm_extract/pdm_load.