Failed Parsing WSDL for Caim Adapter from
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Failed Parsing WSDL for Caim Adapter from

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Article ID: 125283

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

CAIM Main connector does not start from IDP Admin UI , Setup , Connectors Menu.

Error Showed on PopUp Window :

WSDLException: faultCode=PARSER_ERROR: Problem parsing 'http://<hostname>:80/iam/im/TEWS6/identityEnv?wsdl'.: 
org.xml.sax.SAXParseException: XML document structures must start and end within the same entity.
XML document structures must start and end within the same entity.
Reload connector failed 
java.lang.IllegalArgumentException: Failed Parsing WSDL for Caim Adapter from [http://<hostname>:80/iam/im/TEWS6/identityEnv?wsdl] 
Failed Parsing WSDL for Caim Adapter from [http://<hostname>:80/iam/im/TEWS6/identityEnv?wsdl]

Environment

vApp 14.1, 14.2, 14.4

Cause

 The TEWS WSLD File URL defined for CAIM Connector , has a "faulty" WSDL file that is returned from IM,

Resolution

0. Clear the cache of Identity Portal and restart nodes of the cluster. Just to make sure this is not a caching issue.

1. Modify CA Identity Manager Application Log Level to display more details 
 Virtual Appliance supports the logging.jsp file. This file controls logging of configuration logs during the run time. 
Reference :
https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-suite/14-4/virtual-appliance/configuring-virtual-appliance.html

2. Open Idp Management console , and go to Setup
3. Under Settings Menu, Select Connectors
4.  On the right hand section , select the CAIM connector and  click on the name to Edit Connector: CAIM 
5. Select "Webservices" tab , click on "Show Advanced properties" 
6. Scroll down and copy the URL that appears configured under :  TEWS WSLD File URL
ie :
  http://caim-srv:80/iam/im/TEWS6/identityEnv?wsdl&public

7.  Paste the URL into your Browser and try to display its ontent

   http://<hostname>:80/iam/im/TEWS6/identityEnv?wsdl&public 

    it should shows an HTML code. 

8. Press F12 on your Browser (ie. Chrome) to open the Developer Tools and check if you can identity the problem onr the HTML file
9.  From vApp Linux Console use view_im_log command  to confirm what Task is generating the WSDL file Problem. 

    If Debug was enabled Correctly , you should see something like the following into the server.log file when the Error appears and you  search for the problematic TaskName : 
   on this example :    ("TAG"='ForgottenPasswordTeste1)
     
DEBUG [ims.jdbc.JDBCManagedObjectProvider](default task-35)
SELECT DISTINCT("IM.SCREEN"."UNIQUE.NAME") FROM "IM_SCREEN" WHERE "TAG"='ForgottenPasswordTeste1' AND
"IM_SCREEN"."ENV_OID"='3'
.......
ERROR [ims.default] (default task-3) com.netegrity.llsdk6.imsapi.exception.NoSuchObjectException: [facility=4 severity=2 reason=0 status=38 message=No items found]
at com.netegrity.llsdk6.imsimpl.provider.ScreenProviderImpl.getScreenByTag(ScreenProviderImpl.java:123) [imsapi6.jar:]
at com.netegrity.ims.tabhandlers.ForgottenPasswordSearchHandler.initQnAProperties(ForgottenPasswordSearchHandler.java:2396) [ims.jar:]
at com.netegrity.ims.tabhandlers.ForgottenPasswordSearchHandler.init(ForgottenPasswordSearchHandler.java:300) [ims.jar:]
at com.netegrity.ims.tabhandlers.ForgottenPasswordSearchHandler.init(ForgottenPasswordSearchHandler.java:277) [ims.jar:]
at com.netegrity.ims.tabhandlers.ForgottenPasswordSearchHandler.genSearchSchema(ForgottenPasswordSearchHandler.java:1738) [ims.jar:]
...
Caused by: [facility=4 severity=2 reason=0 status=38 message=No items found]
at com.netegrity.llsdk6.imsimpl.provider.ScreenProviderImpl.getScreenByTag(ScreenProviderImpl.java:123) [imsapi6.jar:]
..
ERROR [io.undertow.request] (default task-3) UT005023: Exception handling request to /iam/im/TEWS6/identityEnv: 
java.lang.IllegalStateException: UT010005: Cannot call getOutputStream(), getWriter() already called
at io.undertow.servlet.spec.HttpServletResponseImpl.getOutputStream(HttpServletResponseImpl.java:329) 
[undertow-servlet-1.1.0.Final.jar:1.1.0.Final]

10. Once identified the problematic Task Name , from IM User Console, got to modify "Roles and Tasks" and Disable the WebServices Option for the
     problematic task.
11. restart_im 
12. you should be able to start the CAIM connector from IDP UI. Else , repeat the Test Procedure and check view_im_log again.

 

Additional Information

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-suite/14-4/virtual-appliance/configuring-virtual-appliance.html