UpgradeReadinessCheck Tool is not Working

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Article ID: 125252

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) AXIOMATICS POLICY SERVER CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

When we attempt to run the UpgradeReadinessCheck tool on 12.8.1, we see the following error:

INFO: Starting UpgradeReadinessCheck .....
ERROR: Connection to Policy Store failed.

Full output :

 

  UpgradeReadinessCheck tool failed to start

  UpgradeReadinessCheck tool, which identifies 32-bit custom
  binaries and unsupported authentication schemes in the policy 
  store, failed with the following error:
  STDERR:
  STDOUT: INFO: Starting UpgradeReadinessCheck ....

  ERROR: Connection to Policy Store failed.
  RETURN: -1
  This typically occurs because the tool could not access the policy 
  store. Check that Layer7 SiteMinder Policy Server is running and 
  that you entered the correct super user password and try again.


 How can we fix this ?

Cause

The tool is only able to connect to the default Policy Server authentication port (44442).  The 12.8.1 version of the tool, as well as lower versions have no way to connect to a non-default authentication port.

Here are the default ports :

  Settings

  Authentication Port (TCP) 44442
  Authorization Port (TCP) 44443
  Accounting Port (TCP) 44441
  Administration Port (TCP) 44444

Environment

Release: MSPSSO99000-12.8-Single Sign-On-for Business Users-MSP
Component:

Resolution

This will be fixed in a future release.  A Development Fix is available for customers who either cannot wait for a released version or cannot temporarily switch to the default authentication port (44442) as a workaround.