Update Product Release Fails using FTP connections for downloads

book

Article ID: 124952

calendar_today

Updated On:

Products

CA Mainframe Software Manager (Chorus Software Manager)

Issue/Introduction

Attempting to run an Update Product Release for any product release fails with:

The Tomcat log shows: 
-------------------------------------------------------------------------------------------------- 
Caused by: java.io.IOException: Stream closed 
-------------------------------------------------------------------------------------------------- 

----------------------------------------------------------------------------------------------------- 
Request is using FTP connections for downloads. 
Download error detected. Reported failing 2 packages. DVD11101249E.pax.Z was not inserted into the catalog. 
FTP Message: Error in downloading file /u/users/msmserv/mpm/tmproot/MSM.8533611721969088037.scratchpad/task4678/DVD11101249E.pax.Z: org.apache.commons.net.io. : IOException caught while copying. Download error detected. Reported failing 2 packages. OPS135ICL.pdf was not inserted into the catalog. 

--------------------------------------------------------------------------------------------------

 

Cause

This occurs when the site is either blocking access or the user in question has not been granted access to 
  • ftpdownloads.ca.com (using FTP Port Number 21)

Environment

Release:
Component: MSM

Resolution

    In order to use FTP for downloads the Network Administrator must configure access to 
    • ftpdownloads.ca.com (using FTP Port Number 21
    As a circumvention, you can try using the option to 'Use HTTPS for Downloads'
    To  'Use HTTPS for Downloads' follow the steps below: 
    - Go into CA CSM, click the Settings Tab and then under System Settings select Software Acquisition 
    - Under  Acquisition Options, put a check in the box next to 'Use HTTP for Downloads'
    - Scroll to the bottom of the page and click APPLY to make the change effective
    - Try the Update Product Release Task again and most likely it will be successful.


     

    Additional Information

    https://docops.ca.com/ca-chorus-software-manager/6-1/en/administrating/ca-csm-implementation-and-status/implementation-checklist/network-administrator