Client Automation - Online CIC - CA Content Import Client service fails to start
search cancel

Client Automation - Online CIC - CA Content Import Client service fails to start

book

Article ID: 124925

calendar_today

Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

CA Content Import Client service fails to start and give error "Error 1067: The process terminated unexpectedly".

In log C:\Program Files (x86)\CA\SC\CIC\logs\Wrapper.log following error could appear :
 
[Fatal Error] :1:1: Content is not allowed in prolog.
[com.ca.sccc.CCException] - Exception caught.  Stack Trace:
[com.ca.sccc.CCException] - org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content is not allowed in prolog.
...
[com.ca.sccc.CCMain] - Failed to load configuration data from Config.xml, aborting


and/or in log C:\Program Files (x86)\CA\SC\CIC\logs\CIC.log 
 
org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content is not allowed in prolog.
Failed to complete message types configuration

 

Environment

Client Automation 14.0, 14.0 SP1, 14.0 SP2
Content Import Client Online Mode.

Cause

This problem could occur if the file C:\Program Files (x86)\CA\SC\CIC\conf\config.xml and/or file C:\Program Files (x86)\CA\SC\CIC\conf\MsgProperties.xml are corrupted.

Open these files with notepad and check if they are valid xml file or contain strange or invisible characters.

 

Resolution

Restore the corrupted files C:\Program Files (x86)\CA\SC\CIC\conf\config.xml and/or file C:\Program Files (x86)\CA\SC\CIC\conf\MsgProperties.xml from backup.

If there are no available backup of these files, install a new CIC in mode ONLINE EXPORT using same installation path on another computer.
Once new CIC installed, copy the files CIC\conf\config.xml and CIC\conf\MsgProperties.xml to machine with problem.