New UX Timesheets Total Available Hours not matching the Resource's Availability in PPM

book

Article ID: 124908

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

In Modern User Experience (UX), Available Hours is not reflecting availability correctly based on what is set in Home->Resources.
  1. On the New UX Timesheets there is a section which shows Hours like 33 (entered hours)/40 (available hours).
  2. The resource availability is set as 7 in Classic PPM Home->Resources, but still the above section displays Totals for the timesheet as 33/40 instead of 33/35
Can the hours be changed to the correct availability?

Cause

  • This is because the available hours is pulled from the resource's calendar hours versus availability.
  • Best practice is to update the resource calendar hours versus availability as that will correctly update the availability. 

Environment

Release: All Supported Releases
Component: ODTMM

Resolution

Set the calendar shifts for the resource to equal the amount of availability hours that the user should work per day.

Note:
  • If the resource's availability was previously manually changed on the Resource's properties tab this will be out of sync with the calendar.
  • So, you would then also need to manually update the hours for the resource. 

To change the hours:
  • This can be done for one resource on the Resource's calendar tab. 
  • To make the fix for all users, the calendars can be updated in Administration->Project Management->Base Calendars. 
  1. In base calendars, click on the calendar to be updated then the Calendar tab 
  2. Select the check box for all work day headers (Mon - Fri) 
  3. Click Set Shifts 
  4. Update the hours worked to equal the preferred availability per day 
  5. Save the changes 
  • If the availability has already been changed for those resources, this can be manually updated on the Resource's properties tab.
  • To do an automated update to update a large number of user's a XOG could be used
    • Note that the time slicing job may take longer to process the first time after the updates
    • It's recommended to do this after hours as it could impact performance while the job is processing the large amount of updates.