C1I0012E error after upgrading Endevor
search cancel

C1I0012E error after upgrading Endevor

book

Article ID: 124827

calendar_today

Updated On:

Products

Endevor Endevor Natural Integration Endevor - ECLIPSE Plugin Endevor - Enterprise Workbench

Issue/Introduction

Just installed Endevor v18.0.12 on a test LPAR and upon first attempt to get into Endevor getting a :

C1I0012E YOU ARE NOT AUTHORIZED TO ACCESS ANY ENDEVOR ENVIRONMENTS 

What is missing? 

Environment

All supported versions of Endevor

Cause

The user is not set up in the external security package (RACF, ACF2, or Top Secret) to access the pseudo data sets created by the BC1TNEQU table for the Endevor Environments. 

Resolution

1.  Run this Print Element job with the Options with the ESI traces specified:

//PRTELMNT EXEC PGM=NDVRC1,DYNAMNBR=1500,PARM='C1BM3000',REGION=4096K
//STEPLIB  DD DISP=SHR,DSN=hlq.C1xxxx.CSIQAUTU
//         DD DISP=SHR,DSN=hlq.C1xxxx.CSIQAUTH 
//CONLIB   DD DISP=SHR,DSN=hlq.C1xxxx.CSIQLOAD 
//C1PRINT  DD SYSOUT=* 
//C1MSGS1  DD SYSOUT=* 
//SYSOUT   DD SYSOUT=*       
//SYMDUMP  DD DUMMY       
//SYSUDUMP DD SYSOUT=*       
//*           
//EN$TROPT DD SYSOUT=*       
//EN$TRESI DD SYSOUT=*      
//BSTERR   DD SYSOUT=*           
//*           
//BSTIPT01 DD *           
  PRINT ELEMENT xxxxxx       
   FROM ENV xxxxx         
        SYSTEM xx         
        SUBSYSTEM xxxxxxx 
        STAGE *           
        TYPE *               
   TO FILE C1PRINT           
   OPTIONS NOCC           
.     
/*              


2.  In the ESI trace output look for the data set name the user is being denied access to:

ENCS101I Entity=NDVR.ENVIRON.PROD 
ENCS101I User <userid> access is denied from SAF 
ENCS101I RACROUTE RC=0004 RACHECK RC=0004 Reason=0000 



3.  Have the security administrators set up the user with the proper access.  
 

Additional Information

For further information, see:
Set Up ESI Security