Error opening RC Viewer on an Agent
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Error opening RC Viewer on an Agent

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Article ID: 124373

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Updated On:

Products

CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

While opening Remote Control Viewer on an Agent, the following error is displayed:


Which points out to the following DLL: ..CA\DSM\bin\gui_rcSAReplay.dll, but this file is already there.

Clicking OK, the following message may also appear:

Explorer GUI
"No se pueden encontrar/cargar complementos que utilizan el lenguaje ESN."

Which can be translated to something like: "The complement can't be found/loaded for language ESN".

 

Environment

Client Automation 14, 14 SP1 and 14 SP2

Cause

The error message means the Agent is configured to use Spanish langage, which is not supported for any administrative tool like DSM Explorer, according to Compatibility MAtrix:

https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/release-announcements/CA-Client-Automation-Compatibility-Matrix/5117

Resolution

In order to solve this issue, the language of the Agent must be changed to English, or other supported by the Manager itself (English, French, German, Japanese). The way to change back the language is explained here:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/clarity-client-automation/14-0/implementing/post-installation-tasks/changing-the-product-language-after-installation.html