CA InterTest/Batch GUI unable to see job in Batch Link Queue
book
Article ID: 124252
calendar_today
Updated On:
Products
InterTest - CICSInterTest - Batch
Issue/Introduction
Customer had problem connecting to a Batch session submitted from eclipse (using the asmdemo sample). The job goes to mainframe O.K., but we can't see it under "Batch link queue"
Environment
Intertest 11.0 GUI setup
Cause
We found that debugging never started after submitting the job .
Job will appear in Batch link queue for GUI only if we suspend the debugging session by pressing the "Cancel" and thus the problem is not with Batch link queue but with starting debugging session. Establishing communication from 3270 to windows PC is not working in this case and thus we need to verify if the port can be listened Mainframe to PC .
Resolution
After configuring the firewall rules to open the port used, this started to work.
Additional Information
The connection can a be verified using TSO TELNET command
Step 1.Start listening to the port from the windows side tool for TCP server. You can use any TCP/IP port listener tool which allows to send and receive data.
Note:(Please use the same port number as in submitted JCL)
Step 2:Use the following command in 3270
tso telnet ip_address port_no
First parameter should be replaced with the IP address of the windows PC Second parameter is the port number which is being listened by the port (please use the same port number used for submitted JCL) .
Following message will be received
EZA8200I MVS TCP/IP TELNET CS V2R2
EZA8256I Connecting to xx.138.66.80, port TELNET (23).
Step 3:Try sending and receiving some data from TCP server listener tool .