Clarity Audit Trail Not Logging Activity For An Object
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Clarity Audit Trail Not Logging Activity For An Object

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Article ID: 124191

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Audit trail is not working for a custom object even though it appears to be set up properly on the Audit Trail tab of the object.
There are no entries nor updates on the Audit tab for the object instance.

Cause

This happens occasionally when the function that is created in the database that allows Audit Trail to work is corrupted or created incorrectly.

Resolution

1.  Go to Administration, Objects.
2.  Locate your problem object and open it.
3.  Click on the Audit Trail tab.
4.  Take a screenshot of how Audit trail is currently set up or record it in some other way.
5.  Remove all attributes from the Selected column.
6.  Click the save button.
7.  Add all attributes back the way they were originally.
8.  Click the save button again.

At this point, make a change to one of the audited attributes on an object instance and check the Audit tab to see if the changes are recorded or not.