Clarity fails with java.lang.NoClassDefFoundError java/sql/Connection on com.compuware.apm.agent.introspection
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Clarity fails with java.lang.NoClassDefFoundError java/sql/Connection on com.compuware.apm.agent.introspection

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Article ID: 124160

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Updated On: 11-11-2021

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Clarity Upgrade failing with error java.lang.NoClassDefFoundError java/sql/Connection on class com.compuware.apm.agent.introspection in install.log
 
1/03/19 9:22 AM (ExecTask) Exception in thread "main" java.lang.NoClassDefFoundError: java/sql/Connection
1/03/19 9:22 AM (ExecTask) at com.compuware.apm.agent.introspection.jdbc.ConnectionPoolIntrospection.updateConnectionClass(ConnectionPoolIntrospection.java:214)
1/03/19 9:22 AM (ExecTask) at com.sun.proxy.$Proxy4.prepareCall(Unknown Source)
1/03/19 9:22 AM (ExecTask) at com.niku.union.persistence.utils.Utils.createStatementInternal(Utils.java:704)
1/03/19 9:22 AM (ExecTask) at com.niku.union.persistence.utils.Utils.createStatement(Utils.java:668)
 

Environment

Release: Any

Cause

This issue is not caused by the Clarity product, it's caused by a customization (third party product):

  • com.compuware.apm.agent.introspection
  • Dynatrace by Compuware
  • This is not a Clarity code class.

Resolution

  • We suggest to work with Dynatrace support to resolve this
  • We have been told that Dynatrace  RUM (Real User Monitoring) may have to be disabled for the duration of the upgrade