Spectrum Alarm Notifier Not Running
search cancel

Spectrum Alarm Notifier Not Running

book

Article ID: 124099

calendar_today

Updated On:

Products

Spectrum Network Observability

Issue/Introduction

Alarm Notifier is not running nor am I able to start it manually.  When checking the NOTIFIER.OUT log, we see the following error:

Location Service on $HOSTNAME: failed to connect, not listening on port 0xdaff. Check that the server is started and ready. 

Environment

Release:21.2.x
Component: SPCAEM

Cause

The Location Server is not listening on port 0xdaff (decimal 56063)

Resolution

Restart the Location Server:

Windows:
1. Access Windows Task Manager
2. End Task on the process "LocServer"

Linux:
1. ps -ef | grep LocServer | grep -v grep
2. Find the "pid" shown for the LocServer, it should be the first number after the user that executed the LocServer initially
3. kill -9 pid

Once the LocServer is killed, processd will start another version of the Location Server.  As a more invasive but alternative way to accomplish the same as the above, would be to restart the Spectrum operating system in its entirety.