After installing UIM the data engine does not start and it fails connecting to SQL
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After installing UIM the data engine does not start and it fails connecting to SQL

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Article ID: 123489

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

This is a new install of 9.0.2 and using MS SQL 2016, no TLS. We installed a primary hub and the data_engine is starting properly. After installing on a secondary hub to setup HA, the data_engine won't start. If I start the UIM Install process on the secondary hub, the DB setup and test button work fine. In the \Nimsoft\probes\slm\data_engine\data_engine.log we find the following error:

de: COM Error [0x800a0e7a] Unknown error 0x800A0E7A - [ADODB.Connection] Provider cannot be found. It may not be properly installed.

Environment

UIM 9.0.2
Windows 2016
SQL Server 2016

Cause

This was occurring because a SQL client odbc driver is missing on the server.

The UIM installation installs a 'SQL Server Native Client 11.0' driver, but this did not occur.

Resolution

You can check if the driver is installed by doing the following:

1. Open your 'Administrative Tool' gui.

2. Open the 'ODBC Data Source (64 bit)' icon.

3. Select the 'Drivers' tab.

4. Check to see if the 'SQL Server Native Client 11.0' is listed. If the driver is missing you can manually run the sqlncli.exe install.

It should be in the following folder where your UIM server was installed: \Nimsoft\install\setup\win\SQLNativeClient11