Identity Portal error "Query result does not found"
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Identity Portal error "Query result does not found"

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Article ID: 123333

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

When accessing the CA Identity Portal modules "My Profile" or "My Requests" the "Latest Activity" section displays
the error "Query result does not found".  Clicking on "More Details" button displays the full stack trace.

The stack trace and error are logged in the wildfly-console and IP logs. 

2018-12-07 20:54:45,112 ERROR [com.idmlogic.sigma.workers.utils.ExceptionsHelper] (default task-17) : ErrorCode: 0, ErrorFamily: GENERAL, Message: com.idmlogic.sigma.common.exceptions.SigmaException: Risks are not enabled, you can enable risks from general configuration 
at com.idmlogic.sigma.web.controller.RiskRuleController.checkRisksEnabled(RiskRuleController.java:76) [classes:] 
at com.idmlogic.sigma.web.controller.RiskRuleController.getRisk(RiskRuleController.java:40) [classes:] 
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.8.0_71] 
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) [rt.jar:1.8.0_71] 
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_71] 
at java.lang.reflect.Method.invoke(Method.java:497) [rt.jar:1.8.0_71] 
at org.springframework.web.method.support.InvocableHandlerMethod.doInvoke(InvocableHandlerMethod.java:221) [spring-web-4.2.9.RELEASE.jar:4.2.9.RELEASE] 

 

Environment

CA Identity Suite 14.2

Cause

The issue has identified as being a failure to apply sticky sessions in the cluster deployment.

Resolution

"Sticky Sessions" is a method used with Application Load Balancing, to achieve server-affinity. A router or load balancer with sticky-session support can assign a single server to a particular user, based on their HTTP session or IP address.  If this is not working the user activity cannot be retrieved and displayed in the Identity portal session.  

To workaround this issue shutdown one of the cluster nodes, this will enable the Identity Portal to function as expected, while you configure the cluster to support sticky sessions.

Additional Information

The specific steps require to configure sticky sessions is dependent upon the application host (ie JBoss\Wildfly).  Please refer to JBoss\Wildfly product documentation for guidance.