Portlet are not configurable
search cancel

Portlet are not configurable

book

Article ID: 122949

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

We have few portlets where it does not allow users add/removed columns from the Layout using the configure option. They return "System error contact system administrator". Why is this happening?

Environment

Release:
Component: ODSTU

Cause

it is unknown why portlet became corrupted.

Resolution

XOG out the problematic portlet and XOG back in unchanged.

You can use below XOG input file for reading portlet

<?xml version="1.0" encoding="UTF-8"?>
<NikuDataBus xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/nikuxog_read.xsd">
  <Header version="8.0" action="read" objectType="contentPack" externalSource="NIKU">
    <args name="singleContentType" value="portlet"/>
    <args name="no_dependencies" value="true"/>
  </Header>
  <PortletQuery>
    <Filter name="code" criteria="EQUALS">portlet_id</Filter>
  </PortletQuery>
</NikuDataBus>