Error adding CA Spectrum as a data source in NetOps Portal
search cancel

Error adding CA Spectrum as a data source in NetOps Portal

book

Article ID: 122866

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management

Issue/Introduction

I tried adding CA Spectrum one click server- 10.3 as a data source in NetOps Portal 3.6 and I get an error as a version compatibility issue.

we see this message in the PCService.log on the capc host:

Com.ca.im.portal.api.services.datasource.DataSourcePoll | received WebServiceException from version check for data source Spectrum Infrastructure Manager@<hostname>. Cause=java.net.connectexception: connectexception invoking http://<hostname>:8080/axis2/services/datasourcews: connection refused (connection refused). Message=could not send message.. returning DS_COMM_FAILURE result.error | qtp1441647626-279544 | date time | Com.ca.im.portal.api.servicesdatasource.datasourcepoll

Environment

NetOps Portal 3.x
Spectrum 10.3

Cause

we were trying to use port 8080, but spectrum was running on port 80


 

Resolution

reset data source for correct port and test

please check the file:
*:\win32app\Spectrum\tomcat\conf

to confirm the port in use:

<Connector port="80" URIEncoding="UTF-8" maxHttpHeaderSize="8192" maxThreads="150" minSpareThreads="25" enableLookups="true" redirectPort="8443" acceptCount="100" connectionTimeout="20000" disableUploadTimeout="true" tcpNoDelay="true" />