Jaspersoft Studio error 404/401 if 'Use SOAP PROTOCOL ONLY' is checked
search cancel

Jaspersoft Studio error 404/401 if 'Use SOAP PROTOCOL ONLY' is checked

book

Article ID: 122865

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Connection Error '(404)' or '(401)' when trying to connect from Jasper Studio in SaaS Systems Jaspersoft 7.1.

Environment

Release: All Supported Releases
Component: Clarity Jaspersoft

Cause

This is due to an incorrect setting.

Resolution

  1. Log in to Jaspersoft Studio
  2. Edit the Jasper Reports Server Access Configuration
  3. Click on Advance Setting (+) Symbol to expand the section
  4. Uncheck Use SOAP PROTOCOL ONLY

Note: In Jaspersoft 7.1 you need to clone the existing connection and untick / uncheck USE SOAP Protocol

Additional Information

This behaves differently in Jaspersoft Studio 7.9

By default, (unless the setting is changed), JS Studio will try REST first and then try SOAP.

Some corporate firewalls and/or proxy servers may restrict SOAP or REST.

However, both should work unless there is a corporate policy restricting it.