Connector Server Read failed: Timed out - Return code: 13
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Connector Server Read failed: Timed out - Return code: 13

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Article ID: 122425

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

After a certain period of inactivity, the connection between the Provisioning Server (Virtual Appliance) and Remote Connector Server (CCS for AD endpoint types) stops to work.
The error message is: "Connector Server Read failed: Timed out (ldaps://<jcs_host>:20411) - Return code: 13".
 

Environment

IM 14.x
Remote JCS/CCS on Windows for AD endpoint.
 

Cause

The Firewall between PS and the Remote Connector Server closes the channel because of idle time (no data traffic); this behavior is confirmed by customer's network administrator that also said this configuration can not be disabled.

Resolution

From the Provisioning Server Linux box, Run the following script to cause a remote connection to Connector Server every half hour:

#!/bin/sh 
while true 
do 
etautil -d im -u etaadmin -p <password> select 'eTNamespaceName=ActiveDirectory' eTADSDirectory eTADSDirectoryName=<ENDPOINTNAME> list eTADSdcStatus 
sleep 30m 
done 
 
 

Additional Information

eTADSdcStatus is data location agent and so that will cause a connector server search request against Connector Server.

Script can be created and started in background after switched to "imps" ID. 
Also can be killed by "config" ID.