Clarity PPM: Transactions not processed by the Post to WIP job
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Clarity PPM: Transactions not processed by the Post to WIP job

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Article ID: 122228

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

The following symptoms are experienced:
Imported or manual transactions do not appear on the project task assignments or cost plans, even after running the required jobs: Post Transactions to Financials, Post to WIP, Import Financial Actuals.
The transactions are stuck in the PPA_TRANSCONTROL table and not being processed by the Post to WIP job.
When going to the Home > Financial Management > Post to WIP page and clicking the All button, no transaction are returned. 

Cause

The reason why they are not being processed is because one or more transactions have a future transaction date compared to the current date.

Resolution

This is by design and is documented as
Broadcom Documentation: Set up Financial Transactions

Note: If you do not enter any dates (start date or end date), all available transactions from any past date are pulled up to the current (today’s) date. So, to post any available transactions with a future date you must specify an end date.