CMDB for z/OSNetSpy Network PerformanceNetMaster Network AutomationSOLVENetMaster Network Management for SNANetMaster Network Management for TCP/IPNetMaster File Transfer ManagementSOLVE:Operations AutomationSOLVE:Access Session ManagementSOLVE:FTSSOLVE:Central Service Desk
Issue/Introduction
During initialization of the Netmaster or SOLVE region, /PARMS $RM MULTISYS fails.
JESMSGLG indicates that the parameter group failed.
ILOG shows Time Log Data 08.52.28 IAIN0126 Processing for parameter group $RM MULTISYS started 08.52.28 IAIN0124 Global variable GLBL$RMLETOP set to "60" 08.52.28 IAIN0124 Global variable GLBL$RMAMSPE set to "VTAM=YES EPS=YES TCPIP=YES" 08.52.28 RMINWI54 MULTISYSTEM LINK RECORD $RMVET REPLACED 08.52.28 RMINWI54 MULTISYSTEM LINK RECORD $RMVEX REPLACED 08.52.28 RMINWI54 MULTISYSTEM LINK RECORD $RMVXT REPLACED 08.52.28 RMINWI54 MULTISYSTEM LINK RECORD $RMVXX REPLACED 08.52.28 RMINWI54 MULTISYSTEM LINK RECORD $RMXET REPLACED 08.52.28 RMINWI54 MULTISYSTEM LINK RECORD $RMXEX REPLACED 08.52.28 RMINWI54 MULTISYSTEM LINK RECORD $RMXXT REPLACED 08.52.28 IAIN0133 Parameter group $RM MULTISYS action failed, proc=$RMINWIZ RC=8 08.52.28 IAIN0178 Processing for parameter group $RM MULTISYS ended, status is FAILED
It is not possible to make changes to the parameter group in an effort at correcting the problem. No other errors appear. Setting INIDEBUG=YES in the RUNSYSIN shows nothing additional.
Environment
All SOLVE and Netmaster products
Cause
RAMDB may be corrupted.
Resolution
If the RAMDB was corrupted, how to handle this depends on the content of the file.
If the RAMDB does not contain customized data that is difficult to replace, the following steps will resolve the problem:
1. Stop the Netmaster region (SSI is not impacted) 2. Delete/define the RAMDB using the pertinent section of the S01LCALC job. 3. Run the LDRAM step of the S04LDVSM job. 4. Restart the region
If the RAMDB contains customized data that is difficult to replace, an attempt should be made to repair the file. One option is to see if a backup of the RAMDB is available prior to corruption and restore that version. The other is to run through the steps in Technical Document KB000055433, section titled Fix a Corrupted NDB, to check and possibly repair the existing RAMDB.
Additional Information
Link for KB000055433: https://comm.support.ca.com/kb/understanding-netmaster-databases/kb000055433