Login to Identity Portal fails with "Request Failed" error
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Login to Identity Portal fails with "Request Failed" error

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Article ID: 121352

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

After Identity Portal and SSO integration users are getting an intermittent message "Request Failed"
Even after double checking the SSO configuration the problem still persists.

"Protecting CA Identity Portal with CA Single Sign-On" documentation: 
https://docops.ca.com/ca-identity-portal/14-2/en/integrating/protecting-ca-identity-portal-with-ca-single-sign-on 
 

Environment

Identity Portal 14.x (vApp or non-vApp)
Single Sign-On (SSO) 12.x

Cause

The problem is a missing configuration in the SSO SiteMinder side.

Resolution

1) In the SSO (SiteMinder) AdminUI

1.1) Go to Add/Edit realm, Edit the ‘/sigma/rest/resources’

1.2) Set it to be ‘Protected’, make sure the GET and POST rules are included.

2) In the Infrastructure Menu, Agent -> Agent Configuration Object (ACO) and select the ACO for the agent that protects the Identity Portal

2.1) Configure:  set ‘IgnoreExt’ attribute value to ‘.class,.fcc,.scc,.sfcc,.ccc,.ntc,.css,.js,.woff,.woff2,.svg,.ttf,.eot,.json’.



NOTE: Be careful of trailing spaces in the configuration as this can cause erratic behavior or intermittent functionality.