Deleting records from the CA Dispatch RIDF Type=PROCESS queue
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Article ID: 121313
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Updated On:
Products
Dispatch Output Mgmt
Issue/Introduction
We are concerned with all of the entries that we see in the CA Dispatch Report Input Display Facility (RIDF) TYPE=PROCESS queue. Our LDS saturation is usually pretty high and we are afraid that these entries in the PROCESS queue are taking up a a lot of space.
When we attempt to manually delete an entry from the PROCESS queue, we receive the following error :
"DC900422 Cannot Perform Option for this Report"
Environment
z/OS
Cause
The CA Dispatch PROCESS queue under RIDF is a reflection of ALL entries that have been processed by the RPI or MSG subtasks. It's basically a history file of what has been sent through Dispatch. And you will see an entry in the PROCESS queue for every report/MSGCLASS that currently resides in the Online Viewing (OLV) files.
Resolution
There is no need for clients to be concerned with the entries that show in the PROCESS queue. These entries are basically just a view of the LDS HRD2 records of entries in the LDS files. No additional LDS space is being used to display them on the PROCESS queue screen.
And we will not let you MANUALLY delete entries from the PROCESS queue. This is why the "DC900422 Cannot Perform Option for this Report" message is issued.
* Once a REPORT or MSGCLASS entry in Online Viewing (OLV) has been deleted through normal and regular OLV maintenance cleanup processing, (DSEXVIEW or DSEXPSVW), the same entry in the PROCESS queue will automatically be deleted as well.