Mismatch between JobID on View panel and execution jobs original JES job number
search cancel

Mismatch between JobID on View panel and execution jobs original JES job number

book

Article ID: 121309

calendar_today

Updated On:

Products

OM Deliver OM View

Issue/Introduction



Why would we have a mismatch between JobID on View sysout selection panel and the execution jobs actual JES job number?

Environment

z/OS

Cause

Normal z/OS - JES functionality.

Resolution

This mismatch typically occurs when the reports creation job is submitted and/or running on a remote LPAR, and then the report is being sent to CA View from that remote LPAR.

- When you NJE or otherwise transmit job output from one JES complex to another, and the Job ID is already in use in the receiving complex, JES will assign the job output a new Job ID.

- Since release 11.0, CA View will still use the original Job ID, but only when the original job number is present in the SSS2OJBI field of the SSS2 JES control block when the data arrives on the receiving plex.

- If the original Job Id is already in use on the receiving CA View plex, or if the SSS2OJBI field is empty, the NEW Job ID assigned by JES when the output was received will be displayed on the Sysout Selection List. 

Additional Information

See IBM publication "Assignment of JES2 job identifiers" for additional information.