NetOps Data Repository vioperf script error about low disk space
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NetOps Data Repository vioperf script error about low disk space

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Article ID: 121270

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Updated On:

Products

CA Performance Management Network Observability

Issue/Introduction

‘No space left on device’ on Data Repository servers when executing ‘vioperf’ to determine the catalog performance.

When running vioperf to check the specs on the Vertica host, vioperf exits with an error about no space left on device. This host does not have Vertica installed yet. Is this normal and is it OK to continue with the installation?  How can we fix so that we can run vioperf and get a good test?

The error returned is the following:

error running /<PathToScript>/vioperf: SeqWrite: error writing to temp file: No space left on device

We see the error for the catalog directory that has 50 GB of space total and available.

The data directory with 1 TB of space total and available does not show this error.

Environment

All supported DX NetOps Performance Management Data Repository releases

Cause

Insufficient disk space for the catalog directory. Minimum requirements are 100 GB for the catalog directory.

Resolution

Ensure the catalog disk space meets minimum requirements.

Additional Information

See the vioperf documentation topic in the Run Data Repository Diagnostic Utilities documentation topic for additional details.