CABI reports are not successfully running when integrated with Spectrum
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CABI reports are not successfully running when integrated with Spectrum

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Article ID: 121268

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Updated On:

Products

Spectrum

Issue/Introduction

CABI reports are not successfully running when integrated with Spectrum.  The error seen is:

An unexpected error occurred while retrieving data. Please check the user access privileges or run as a different user.

Environment

Release: Any
Component: SPCRPT

Cause

When checking the Spectrum tomcat log (stdout or catalina.out), the following error is also seen:

Nov 34, 2099 10:21:27.075 (http-nio-80-exec-12) (RESTfulWebServices) - (ERROR) - BasicJasperAuth Error: Invalid token found in the request header /t1zS1h0WPkKtfHipouwehbfIUG38732Dhhas5w=

Resolution

The CABI and Spectrum integration utilizes a token to perform REST calls.  This is the token referenced in the above error.  To ensure the token is generated from the most up to date files:

1. Access the CABI system
2. Navigate to:

CABIinstallDir/apache-tomcat/webapps/jasperserver-pro/WEB-INF/config/

3. Rename/Move the existing two files:

spectrum,jks
spectrum.properties

4. Access the Spectrum system
5. Navigate to:

SpectrumInstallDir/tomcat/webapps/spectrum/repmgr/admin/

6. Copy the spectrum.jks and spectrum.properties files from this directory in Spectrum to the below directory in CABI:

CABIinstallDir/apache-tomcat/webapps/jasperserver-pro/WEB-INF/config/

7. Restart CABI services