Scheduler does not create reports and send them as emails
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Scheduler does not create reports and send them as emails
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Article ID: 120930
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Updated On: 04-14-2023
Products
Vantage Storage Resource Manager
Issue/Introduction
The Scheduler List (scheduler is started) shows that the object is executed but the emails of the reports are never sent. However, if you open the object view and then use the email icon, the output is successfully sent as an email.
Environment
CA Vantage Windows Client 12.7.871.5 Running scheduler as a service.
Cause
The OAEXEC.exe task was stuck. OAExec.exe is the output executor task that executes output actions.
Resolution
End the OAExec.exe process and restart the scheduler as an application.
Additional Information
How to check if OAExec.exe is stuck or hangs: - open task manager (accessible in most windows via CTRL+ALT+Delete or right click on windows taskbar) - In Processes tab check show processes from all users - look for the OAExec.exe in the Processes tab - if there is OAExec.exe in Processes tab then scheduled task is running (Task can be running for several minutes or even few hours depending on how much data task should process) - Task is stuck if CPU is 00 and memory is not changing in line with OAExec.exe in Processes tab - If task is stuck select it and click End Process to allow scheduler to run another task
How to check if scheduler is running as an application or as a service: - open task manager (accessible in most windows via CTRL+ALT+Delete or right click on windows taskbar) - In Processes tab check show processes from all users - In Processes tab try to locate SchedulerService.exe to verify that scheduler is running as service - In Processes tab try to locate SchedulerApplication.exe to verify that scheduler is running as application - To verify that scheduler is not running there should not be SchedulerService.exe nor SchedulerApplication.exe nor OAExec.exe in Processes tab
How to make Scheduler as application run on remote server even when you close connection: - Use Lock instead Log off - Close window with remote desktop
See also the description of the Windows Client Scheduler at link - https://support.ca.com/cadocs/0/CA%20Storage%20Resource%20Manager%20r12%207-ENU/Bookshelf_Files/HTML/SRM--Windows%20Client%20User%20Guide/index.htm?toc.htm?1194081.html especially the sections - Scheduler Components - Scheduler as a Windows Service (Windows Client Scheduler) - Scheduler as an Application (Windows Client Scheduler)