Agent fails to start due to "Can't load IA 32-bit .dll on a AMD 64-bit platform" error
search cancel

Agent fails to start due to "Can't load IA 32-bit .dll on a AMD 64-bit platform" error

book

Article ID: 120818

calendar_today

Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

After upgrading a Windows Remote Agent, the Agent fails to start due to error " Can't load IA 32-bit .dll on a AMD 64-bit platform" seen in the AgentService.log file.

Cause

Issue with Java installation or configuration.

Resolution

Applications Manager in Windows moves from a 32big Java requirement in version 9.2.1 and below to a 64bit Java requirement in version 9.2.2 and up.

Uninstall 32bit Java and install 64bit Java or if both Java 32bit and 64bit Java is required on machine,  confirm that Java 64bit is installed and set in the PATH variable.

If set correctly, a 'java -version' command should return 64bit Java, and watchworx should start successfully.