'ERROR DMS-05304: Unable to upload document because the system file scanning program cannot be found. Contact your system administrator.'
search cancel

'ERROR DMS-05304: Unable to upload document because the system file scanning program cannot be found. Contact your system administrator.'

book

Article ID: 120653

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When trying to upload a file into the Knowledge Store, this error appears:

ERROR DMS-05304: Unable to upload document because the system file scanning program cannot be found. Contact your system administrator.

Environment

On Premise PPM environments.

Cause

File scanning of documents is enabled but no file scanner has been configured.

Resolution

Set up or review file scanning configuration on CSA:

  1. In CSA, select Home > Servers and select a specific server.
  2. Under Properties > Documents and Search, review the section Document ManagerFile Scanning Executable.
  3. Save, and restart PPM services.


alternatively, if you want to disable file scanning:

  1. In PPM, go to General Settings > System Options > Document Manager Options.
  2. Deselect Enable File Scanning of Documents.
  3. Save.