Missing RA tabs in AWI
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Missing RA tabs in AWI

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Article ID: 120014

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation CA Automic Operations Manager

Issue/Introduction

Under certain conditions, RA objects (i.e. SOAP job) will be missing tabs when creating or editing an object. The missing tabs will be specific to the RA solution that is related to the object. For example, if you create a WEBSERVICESOAP job the tab titled 'Web Service' would be missing.

Check if the plugin is installed. 

  • Open AWI
  • Click the drop-down on the top right corner of the AWI and choose 'About'
  • This will return a list of installed plugins. Look for the message 'Not Installed Plug-ins'. See the screen capture below:

 

Environment

Product: Automic Workload Automation 12.x, 21.x
Component: AWI

 

Cause

This article will cover two reasons that could potentially cause this issue:

1. The plug-in is missing or corrupt. 
2. The user who started Tomcat does not have permission to the jar file

You can check this by following the steps below:

  • Login to client 0000
  • Open the Process Assembly perspective
  • From the explorer tab, choose the folder 'STORE'
  • The 'STORE' folder contains UC_ECC_PLUGINS object. This includes every plug-in that is currently installed.
  • If the plugin is listed but you don't see the tab this could be caused by the AWI not having permission to access the jar file. Check for the following text in the AWI log file: 

Caused by: java.io.FileNotFoundException: /u00/app/tomcat8/apache-tomcat-8.5.32/temp/ecc-plugins/ecc-plugin-ECC-AE-SHEET-RA-WEBSERVICE-SOAP-504e90361b8ce959d1bc2716bf640b28.jar (Permission denied)

Additional information: Even if the AWI log does not show any permission error message, please check with the customer if the user who started the Jetty or Tomcat has proper rights on /tmp/ecc-plugins

Resolution

First troubleshooting steps:

1. Check that the issue still occurs after restarting the Tomcat server hosting AWI

2. Check if the solution was loaded into db with the below query.

select *from oblob where oblob_name like '%ECC%'

If the solution is in the db try to:

- stop Tomcat

- delete the "<Tomcat Installation directory>/work/" directory - this is a cache directory and gets recreated when Tomcat is restarted

- Start Tomcat

3. Use the HTTP URL of your Tomcat instead of HTTPS as the issue must be linked to an expired certificate on Tomcat.

 

You can run the DB Load utility and load the agent solution if the plugin is still missing.

Alternatively, open the UC_ECC_PLUGINS object and upload the plugin manually.



If the plugin is listed in the UC_ECC_PLUGINS make sure Tomcat is started with a user with root permission.

If using Jetty, please check with the customer if the user who started the Jetty has proper rights on /tmp/ecc-plugins.