Spectrum is asserting the "MANAGEMENT AGENT LOST" alarm on Cisco device models
search cancel

Spectrum is asserting the "MANAGEMENT AGENT LOST" alarm on Cisco device models

book

Article ID: 119916

calendar_today

Updated On:

Products

Spectrum

Issue/Introduction

Spectrum is asserting the "MANAGEMENT AGENT LOST" alarm on Cisco device models running "Cisco IOS Software [Denali], Catalyst L3 Switch Software (CAT3K_CAA-UNIVERSALK9-M), Version 16.3.1, RELEASE SOFTWARE (fc3) "

Environment

Cisco devices running "Cisco IOS Software [Denali], Catalyst L3 Switch Software (CAT3K_CAA-UNIVERSALK9-M), Version 16.3.1, RELEASE SOFTWARE (fc3)"  modeled in any version of Spectrum running on any supported operating system

Cause

Spectrum is sending out snmp requests to the following OID's on these devices:

1.3.6.1.4.1.9.9.48.1.1.1.5 - ciscoMemoryPoolUsed 
1.3.6.1.4.1.9.9.48.1.1.1.6 - ciscoMemoryPoolFree 
1.3.6.1.4.1.232.11.1.1 - cpqHoMibRevMajor 
1.3.6.1.4.1.2.6.159.1.1.30.3.1.1 - ibmSystemComponentHealthKeyIndex 

These OID's are not supported on these devices running "Cisco IOS Software [Denali], Catalyst L3 Switch Software (CAT3K_CAA-UNIVERSALK9-M), Version 16.3.1, RELEASE SOFTWARE (fc3)". The device should immediately respond with "noSuchName". However, when an SNMP query is sent to these OID's, the device stops responding to snmp for over a minute. Since the device does not respond to SNMP for over a minute but does respond to ICMP, Spectrum asserts the "MANAGEMENT AGENT LOST" alarm as expected. 

Resolution

This is an issue with the SNMP agent on the device and should be addressed by the vendor.