No authentication mechanisms supported by both server and client error in mail notifications
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No authentication mechanisms supported by both server and client error in mail notifications

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Article ID: 118908

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Outgoing emails are not being sent out from CA Service Desk Manager (SDM) 17.x

mail_nxd.log show errors like this

2018-11-01 11:53:02:606 ERROR  [mailNxdActorSystem-akka.actor.default-dispatcher-8] c.c.S.m.NXJavaMailMailer - The transport is not connected or is dead.
javax.mail.AuthenticationFailedException: No authentication mechanisms supported by both server and client 

Environment

Release:  17.1 and higher
Component: USRD

Cause

The error happens when SMTP server's authentication mechanism differs from the one that CA SDM is set with.

Resolution

Here are some option combination to resolve the issue, based on how authentication is configured on the SMTP server:
 


SMTP Server Authentication / SDM optionsAuthentication is NOT requiredAuthentication IS RequiredAuthentication is NTLM
mail_login_userid & mail_login_passwordDeinstalledInstalledInstalled
mail_smtp_security_level01 or 42


A restart of mail_nxd or SDM is required after setting these options
 

Additional Information

To verify if authentication is required or not, a test via telnet might be a good idea:

telnet <SMTPServer> <SMTP_PortNumber>    

It would indicate there normally if authentication is needed or not.   

In some cases, the mail server itself was modified to require authentication.  In one such example, a new Auth option was inserted in mail in POP3. Previously it was set as “clear text” and worked. After migration it stopped working. Changing the config to use “login” addressed the issue.