WA Agent fails to upgrade on Windows (Agent inventory)
search cancel

WA Agent fails to upgrade on Windows (Agent inventory)

book

Article ID: 118031

calendar_today

Updated On:

Products

DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation DE - Scheduler (dSeries) Workload Automation Agent CA Workload Automation AE - System Agent (AutoSys)

Issue/Introduction

When upgrading the WA Agent on Windows from Agent Inventory, the installer may fail with similar messages:

XX-01-2023 00:45:58      output form process-
XX-01-2023 00:45:58      ret code--1
XX-01-2023 00:45:58      ret value of installer--1
XX-01-2023 00:45:58     UPGRADE_FAILED
XX-01-2023 00:45:58      In executeRollbackAction
XX-01-2023 00:45:58      Sending status to xxx.example.com:7507
XX-01-2023 00:45:58      curDir as per user.dir-C:\Program Files\CA\WA Agent Distributed\spool\de_agent_cmd\16XXXXXXXX-1fXXXXXXX
22-08-2023 00:45:58      About to execute command:cd
22-08-2023 00:45:58     Exception: Cannot run program "cd": CreateProcess error=2, The system cannot find the file specified

or 

Error! Upgrade backup failed; com.ca.sysagt.utilities.AgentUtilsException
Problem deleting file - jars/librariy.jar

Environment

Windows OS: Any
WA Agent 12.x 

Cause

The error is due to inadequate permissions or some files still being used. 

Resolution

Windows OS may not allow any file that is still being used.

When upgrading the WA Agent make sure:
1.  The Agent has stopped

2.  Stop all the jobs, including file monitor and filewatcher jobs.

If doing manual upgrade:
1.  Run the CA WA Agent setup.exe as administrator. 

2.  Right click on setup.exe and click on "Run As Administrator"