IDM OBJECT12_5 table lock weblogic.common.resourcepool.ResourceDisabledException weblogic.common.resourcepool.ResourceLimitException: No resources currently available in pool
search cancel

IDM OBJECT12_5 table lock weblogic.common.resourcepool.ResourceDisabledException weblogic.common.resourcepool.ResourceLimitException: No resources currently available in pool

book

Article ID: 117684

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

Users report 'Backend Service is Unavailable,' DBA finds contention against task persistence tables, like locks on object_12_5.

Application Server logs show errors like these:

Error:  weblogic.common.resourcepool.ResourceDisabledException: Pool iam_im DataSource-tp is Suspended, cannot allocate resources to applications.. 

BEA-000000> <04:28:01,489 ERROR [ims.tmt.persistence] PersistenceProvider: JMS:ID:<917463.1536250769441.0>: saveTaskSessionEvent: exception saving task session: weblogic.common.resourcepool.ResourceLimitException:
No resources currently available in pool iam_im DataSource-tp to allocate to applications, please increase the size of the pool and retry..

java.sql.SQLException: weblogic.common.resourcepool.ResourceLimitException: No resources currently available in pool iam_im DataSource-tp to allocate to applications, please increase the size of the pool and retry..
                at com.netegrity.idmutils.DBConnectionUtil.getConnection(DBConnectionUtil.java:49)...


 


 

Environment

Identity Manager on WebLogic Application Server

Cause

Insufficient connection pool resources.
The errors above occurred for the task persistence datasource,  iam_im DataSource-tp .

Resolution

Increase the max pool size:

The default values for all Identity Manager connection pools is min=50, max 200.

Ensure that all datasources' connection pools are configured for at least min=50, max=200 connections. If you continue getting that same errors you can increase max value further, as needed. On busy systems we have seen customers set max=700 or more. 

The connection pool settings are available in the Weblogic management console.
  1. Open the WebLogic Server Console
  2. Go to Services > Datasources and select the datasource that you want to change the pool size of
  3. Go to Configuration > connection pool
  4. Change the Maximum Capacity to the count required for your environment