After restarting the Spectrum OneClick process no users can login. 
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After restarting the Spectrum OneClick process no users can login. 

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Article ID: 117607

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

After restarting the CA Spectrum OneClick process, no users can login. 

The tomcat log file ($SPECROOT/tomcat/logs/stdout.log on Windows or $SPECROOT/tomcat/logs/catalina.out on Linux) stops updating after showing alarm.web.model.gatherpoolsize:

Nov 15, 2019 15:04:32.505 (localhost-startStop-1) (GAPM) - GAPM.user preload: 73ms
Nov 15, 2019 15:04:33.413 (localhost-startStop-1) (ALARMS) - Alarm fire timer scheduled at: 10000
Nov 15, 2019 15:04:33.414 (localhost-startStop-1) (ALARMS) - alarm.web.model.gatherpoolsize : 5

No user can log into OneClick.

Environment

Release: Any
Component: Spectrum OneClick

Cause

  • There is a hung CORBA thread between OneClick and *ONE* of the SpectroSERVERs.
  • There is currently no indication in the OneClick logs to indicate which SpectroSERVER has the hung CORBA thread.
  • For the above reason *ALL* SpectroSERVERs and processd instances need to be restarted.

Resolution

Clean up all hung CORBA thread as follows:

  • Stop SpectroSERVER for *ALL Landscapes* in the Spectrum environment.
  • Stop processd services on all SpectroSERVER systems.  
  • *Recycling the SpectroSERVER process only does not resolve the issue.  Both the SpectroSERVER and processd need to be restarted*
  • Once all SpectroSERVER and processd instances have been recycled stop and restart the OneClick tomcat process on the OneClick server.

Additional Information

The following article is applicable to both RHEL and using the bash shell on Windows.

How to start and stop CA Spectrum