SOI 4.2 - Manager/MQ - All services not starting after windows update/reboot
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SOI 4.2 - Manager/MQ - All services not starting after windows update/reboot

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Article ID: 117488

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

 

After deploying the new Windows update and restarting the server, all of the SOI services—CA SOI Integration Services, CA SOI MQ Server, CA SOI Event Management, CA SOI UCF Broker, and CA SOI Application Server—are not starting and cannot be started manually or using soitool.exe.

When trying to start the services the following error is returned:

"INFO | jvm 5 | 2018/10/12 09:02:09 | Error occurred during initialization of VM

INFO | jvm 5 | 2018/10/12 09:02:09 | java/lang/NoClassDefFoundError: java/lang/Object

ERROR | wrapper | 2018/10/12 09:02:09 | JVM exited while loading the application.

FATAL | wrapper | 2018/10/12 09:02:09 | There were 5 failed launches in a row, each lasting less than 300 seconds. Giving up.

FATAL | wrapper | 2018/10/12 09:02:09 | There may be a configuration problem: please check the logs.

STATUS | wrapper | 2018/10/12 09:02:09 | <-- Wrapper Stopped"

Soimgr-error is empty. Soimgr-debug/soimgr - not refreshed since the reboot.

Environment

SOI 4.2

Cause

 

Go to the soi\jre-64\bin\ and run java.exe -version 


The following message appears:


Error occurred during initialization of VM. 
java/lang/NoClassDefFoundError: java/lang/Object 

Running the same command in soi\jre and soi\jre-32, both came back with the version info. 

This means the \soi\jre-64\ is corrupted. 

 Comparison of the jre-64 folder across machines will often show multiple missing files.

Resolution

Copy the jre-64 folder from another SOI server.