API Gateway: Manual License Upgrade
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API Gateway: Manual License Upgrade

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Article ID: 116988

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Updated On:

Products

STARTER PACK-7 CA Rapid App Security CA API Gateway

Issue/Introduction

  • After upgrade to anew major release such as SSG 9.x to 10.x(o r8.X to 9.X), the customer is not able to log back in to update the license. After entering credentials, policy manager goes back to the disconnected mode, and this warning shows up in SSG log:
2018-10-04T14:46:08.424-0400 WARNING 160 com.l7tech.server.admin.AdminRemotingProvider: License checking failed when invoking the method, org.springframework.remoting.support.RemoteInvocation#findAllSecurityZones

Environment

  • API Gateway

Cause

  • The Issue could happen when upgrading SSG to a new Major release.

Resolution

  • Unzip the .lic file to get the xml file.
  • Create a license.sql file, using the SQL commands below:

LOCK TABLES `license_document` WRITE;
/*!40000 ALTER TABLE `license_document` DISABLE KEYS */;
INSERT INTO `license_document` VALUES (unhex(md5(uuid())),0,'
<license Id="... </ds:Signature></license>');
/*!40000 ALTER TABLE `license_document` ENABLE KEYS */;
UNLOCK TABLES;

  • Copy the contents of the license xml file, minus its first line of  <?xml version="1.0" encoding="UTF-8"?>
  • Paste the copied contents from the license file where the highlighted red XML tags are, within the license.sql file
  • Remove the old license from the SSG DB:

# mysql -e "truncate ssg.license_document;"

  • Insert the new license into SSG DB:

# mysql ssg < license.sql

  • Restart the SSG service:

# service ssg restart

  • Login through policy manager, and confirm the new license is OK through Help>Manage Gateway Licenses.

Additional Information

This is an operation not taken lightly and it is recommended to back up your database before making any changes to it.  Broadcom support is not responsible for any manual changes made to your database and recommends reverting to your back up if there are any issues. 

If you are having this issue with a 9.2 or higher gateway while migrating to Gateway 10 we recommend looking at this article on updating your license before upgrading