CA Identity ManagerCA Identity GovernanceCA Identity Portal
Issue/Introduction
We are facing the following topic about the provisioning of IBM Tivoli Diretory Server -TAM entities (account / entitlements). The target system seems to be unable to properly manage parallel calls. A percentage of the operations forwarded from the Provisioning and Connector Server to the target system fail. The customer would like to know if there is a way to modify the behavior of this DYN connector, in order to forward the activities to the target system in a sequential way, not in parallel. For the IBM team this modify should fix the issue.
Environment
2 Servers in HA with Identity Manager deployed on JBOSS EAP 6.4 and all provisioning components installed. - User Store: based on RDBMS MS SQL SERVER 2014 - Application Server in subject :Jboss EAP 6.4 HA - Identity Manager product version :CA Identity Manager 14 SP1 CP5 - Server Operating System :Windows 2012 R2 - Target System in subject :TDS-TAM
Cause
JCS is multi threaded for any JNDI DYN custom connectors.
Resolution
The only way to limit the JNDI connector to work with one active session at a time, would be to override the default behavior which is 20 maximum number of active connections. So copying the \jcs\conf\override\jndi\SAMPLE.connector.xml to connector.xml and updating <property name="maxActive"> to <value>1</value>
Additional Information
This is not supported as not tested. This will drastically decrease the performance if you have a consequent flow against this connector. And if you have JNDI connectors against other technologies then they will be impacted and the performance will decrease for them. If so a dedicated JCS for TDS could be implemented.