After upgrade collector is not connecting.
search cancel

After upgrade collector is not connecting.

book

Article ID: 116814

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) INTROSCOPE

Issue/Introduction

We have one mom with 3 collectors in our environment. We have upgraded CA APM from 10.5 to 10.7 SP2 but after upgrade only one collector is connecting to mom rest of two collector is not connecting.

Environment

APM 10.7 RHEL

Cause

Checking the IntrsocpeEnterpriseManager.log files on all Enterprise Managers in the cluster showed that the Build was not the same. The MOM and connecting collector both showed

Introscope Enterprise Manager Release 10.7.0.115 (Build 991408)

but the collectors failing to connect reported

Introscope Enterprise Manager Release 10.7.0.45 (Build 990045)

The Enterprise Manager versions must be consistent within a cluster

 

Resolution

APM 10.7 SP2 had not applied correctly on problem collectors - once reapplied successfully collectors then connected.