logmon probe not alarming after finding matches
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logmon probe not alarming after finding matches

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Article ID: 116755

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

logmon probe does not seem to be generating an alarm when the watcher profile makes a match with the configured regular expression.

Environment

- UIM 8.5.1
- logmon v3.92

Cause

There were no alarm ATTACH/GET queues to allow the logmon alarms from the robot to make it to the local hub which sends to the Proxy Hub and up to the Primary hub from the robot where logmon was installed.

Resolution

Checked the logmon watcher profile via rt-click and Test Profile and the watcher showed it had a match. The log already showed logmon successfully matching and generating an alarm.

Sep 27 16:20:39:948 [140328414979840] logmon: [Syslog_test] MATCH [catchall] on line 0
Sep 27 16:20:39:948 [140328414979840] logmon: [Syslog_test] Syslog_test.catchall: Alarm Message, severity=4, sid=1.1, msg='Sep 27 16:20:12 xxxxxxxx

The logmon profile mode was set to 'cat' so we set it to 'updates.'

Checked the logmon probe on the given robot. That robot was connected to a local hub.

Upon examination of the hub Status Tab, there were no attach queues for alarms OR QOS like there are on other hubs that are processing logmon alarm data and sending the data to the Proxy Hubs.

So we went ahead and created the missing queues for both alarms and QOS and also created the GET queues on Proxy4. Once the queues were created, we saw alarms being queued up on the hub that was local to the robot. Then the GET queues were processing the alarms and QOS on the Proxy4 (Tunnel), which already had associated queues on the Primary.

At that point, the logmon alarms from the robot were now seen on the Primary hub queue and in the alarm subconsole as expected.