Unable to save tickets in CA SDM. Getting message "Error calling add_ast, cannot process sla bopevt..Arg 3 of type NIL: expected overide_duration of type DURATION"
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Unable to save tickets in CA SDM. Getting message "Error calling add_ast, cannot process sla bopevt..Arg 3 of type NIL: expected overide_duration of type DURATION"

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Article ID: 116694

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When attempting to save a Service Desk Manager ticket, receive an error similar to:

"Error calling add_ast, cannot process sla bopevt.spl:evt::do_new_att_event | bopevt.spl:388:evt::new_attached_event_obj | sla.spl:2510:attached_sla::add_ast Arg 3 of type NIL: expected overide_duration of type DURATION"


Environment

CA Service Desk Manager 17.x

 

Cause

This error is noted if the associated Service Type contains Events with the "Allow time resetting"  field not selected.

The attribute  "Allow time resetting" (evt.user_settime) allows the user (or system) to override the fire time (delay time) that is defined for an event.

For example, when users add an event to a Service Type, they can redefine the fire time for the event only if the user_settime flag is set.  Otherwise, the fire time defined in the event is used.

The system allows the user to create the event with "user_settime" as 0, however, the system does not allow such events to be added to the service type.

Once the service type is created with an event having "user_settime=1", it can be used inside any Service Type. 

Resolution

Review the event related to the Service Type affected. The field "Allow time resetting" should be selected:

Additional Information

The information can be verified via a SQL query against the MDB database:

select sym from evt where user_settime=0

The events used in the Service Type should not be shown in the results of the query as they should have value=1.