Error "Access is Denied" running a report when 'Allow Jaspersoft Roles Sync' is unchecked
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Article ID: 116686
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Updated On: 01-16-2025
Products
Clarity PPM On Premise
Clarity PPM SaaS
Issue/Introduction
You are receiving the below error when you attempt to run jasper reports using Advanced Reporting in Clarity:
org.springframework.security.access.AccessDeniedException: Access is denied
Environment
Release: Any
Component: Clarity Jaspersoft
Cause
This can happen if Allow Jaspersoft Roles Sync is not checked
Resolution
- Go to Administration > System Options and ensure the "Allow Jaspersoft Roles Sync" box is checked
- Run the Sync Jaspersoft Roles job and ensure it completes successfully
- Run the Create and Update Jasper Users job and ensure it completes
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