Windows Agent Will Not Start After Upgrade - Error 1067
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Windows Agent Will Not Start After Upgrade - Error 1067
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Article ID: 116681
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Updated On: 10-11-2023
Products
CA Workload Automation AE - Business Agents (AutoSys)CA Workload Automation AE - Scheduler (AutoSys)Workload Automation Agent
Issue/Introduction
After upgrading an agent on Windows, the service will not longer start. When attempting to start it from Windows Services, it immediately stops and an error pop-up appears saying "Error 1067 - The service terminated unexpectedly."
Environment
Release: Component: SYSAGT
Cause
This problem will occur if a 64-bit agent is upgraded using a patch/iso meant for the 32-bit agent...or vice versa.
Resolution
In order to repair an agent installation that has been upgraded with the wrong patch/iso, it must be uninstalled and then reinstalled. To save time, reinstall the agent using the iso for the version to which you are upgrading rather than installing the older version first and then upgrading.