After updating LDAP parameters, user name still not showing up
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After updating LDAP parameters, user name still not showing up

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Article ID: 116669

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Updated On:

Products

CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

I have updated the HServer.arg file according to directions, and still the Harvest user's real name is not being populated. Why is this?

Environment

CA Harvest SCM all versions and platforms

Cause

If you have selected to authenticate users through LDAP, Harvest does not maintain any information about the user in the database.  Instead, it will gather those details from the LDAP database, according to the settings you have for the following options:

The following options apply only to CA Harvest SCM servers.

Enter or modify these options in the server's HServer.arg file.

-ldapattrusrfullname=attribute-name
(Optional) Defines your LDAP server's user attribute name for Full Name.
Default: fullName
-ldapattrusrphone=attribute-name
(Optional) Defines your LDAP server's user attribute name for Phone Number.
Default: telephoneNumber
-ldapattrusrphoneext=attribute-name
(Optional) Defines your LDAP server's user attribute name for Phone Extension.
Default: telephoneExtension
-ldapattrusrfax=attribute-name
(Optional) Defines your LDAP server's user attribute name for Fax Number.
Default: facsimileTelephoneNumber
-ldapattrusremail=attribute-name
(Optional) Defines your LDAP server's user attribute name for eMail.
Default: mail

Resolution

Add any of the above options to your HServer.arg file in order to populate the Harvest database with the corresponding data from the LDAP server.

Additional Information

For more information, see the following article in the Harvest documentation:

https://docops.ca.com/ca-harvest-scm/13-0/en/installing/configure-broker-and-server-communication/configure-broker-and-server-on-unix-linux-and-zlinux

Look for the section titled: "OpenLDAP External Authentication Connection Options (Servers)"