Service desk catalyst connector fails to start after it was stopped.
Environment
SOI 4.0 & 4.2 SDM Version: 17.1
Cause
Looking at GRLoader.log, following exceptions found...
GRLoader 496 GRLoader Started - load from xml file(X:\Program Files (x86)\CA\Catalyst\CatalystConnector\container\resources\ServiceDeskManager-GRLoader.xml) - to CMDB - CI Updates allowed / inserts allowed GRLoader 504 GRLoader run with options: -N X:/PROGRA~1/CA/SERVIC~1 -u soi -p <password> -s https://<SDM Host>:8443 -T 10 -a -n -E -api -i X:\Program Files (x86)\CA\Catalyst\CatalystConnector\container\resources\ServiceDeskManager-GRLoader.xml grDataMgr 2281 cmdb_get_cmdb_version not available, Reason:AHD03301:This operation requires Function Access for admin equal to Modify
ServiceDeskManager.connector.log:
FATAL [com.ca.sdm.connector.ConnectorHelper] - Unable to connect to Service Desk Manager. com.ca.sdm.connector.grloader.GRLoaderInitializationException: GRLoader Initialization Failed. Please check the GRLoader parameters and try Again. Initialization value =1 at com.ca.sdm.connector.grloader.GRLoaderInitializer.initialize(GRLoaderInitializer.java:47)
Resolution
This could be due to wrong ServiceDesk Manager details in Catalyst configuration files
1) Make sure the UserName case in CA ServiceDesk Manager matches in the configuration files