cam hung with unable to connect to cam server on ITCM ITCA SS or DM systems
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cam hung with unable to connect to cam server on ITCM ITCA SS or DM systems

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Article ID: 116581

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Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

Users may see a recurring issue where, typically, Scalability Servers and/or Domain Managers experience a CAM not responding error or are otherwise unable to communicate. Rebooting the system may seem to be required to fix it or before commands like 'camping' or 'camstat -a' will work again.

Various CAM/CAF/CAM-Related commands may return the message: "Unable to connect to CAM server"

Environment

Release: UASMGT60000-1402-Asset Management
Component:

Cause

One of the common causes of issues like this is when an environment needs to generate CAM.CFG files on these systems and generates them via one of the following commands:

CAMSAVE CONFIG*

CAMSAVE PERSIST

*NOTE: CAMSAVE CONFIG generates a file in %CAI_MSQ% just as CAMSAVE PERSIST does, but instead of generating a CAM.CFG file it creates a safe file called SAVE.CFG which can be used for reference and which CAM will ignore. This is typically renamed to CAM.CFG after edits are made.

What happens when the commands are run is that ALL current configuration, Network and Routing details CAM has stored in memory, is dumped to this file. 99% of this info may be at the least unnecessary and as the number of PATHS and ROUTING entries rise, CAM can go to slow and ultimately non-responsive.

Resolution

To correct this issue, take the following steps:

1. Run 'CAF STOP ALL'
2. Use Windows Task Manager to kill any processes that may be hung
3. Open an administrative command prompt and run 'CAM change disabled'**
4. Run 'CAM stop**
5. Run 'csampmux stop'
6. Browse to "%CAI_MSQ%" and open CAM.CFG with Notepad.
7. Remove ALL entries under the ROUTING section that contain the string '(to)' at the end of the line, or all lines if no customizations have been added by you.
8. Remove ALL entries in the PATHS section except for items that end in 'PROTOCOL = TCP' and only if they were manually created or known to be needed. All the rest should be removed.
9. Save the CAM.CFG file or of Windows does not permit this, save as CAM.CFG (not CAM.CFG.TXT as sometimes happens) to the desktop and then manually drag-drop the file back into %CAI_MSQ%, selecting to overwrite the existing file when prompted.
10. Run 'CAM Change Auto & CAM Start -c -l'
11. Run CAF START (or CAF START ALL if using Health Monitoring on the system)
12. Test

**If this command fails, open Windows Task Manager and manually kill 'CAM.EXE'. Make sure it automatically relaunches itself, then try the command again.